编译树莓派2代B型OpenWrt固件实现无线路由器及n

作者: 金沙澳门官网网址  发布:2019-08-28

提起底效果:

编写翻译托盘派2代B型OpenWrt固件落到实处有线路由器及nodogsplash认证功用,openwrtnodogsplash

终极效果:

有线路由器的重要作用,网口WAN接入,USB有线网卡AP紧俏输出,连上wifi之后跳转到认证页面,点击认证方可上网,有效时间10分钟,认证成功之后自动访谈钦赐网站。

作品最终有编写翻译好的刷机包下载

硬件希图:

1.Raspberry Pi 2 model B

2.USB有线网卡,作者动用的是TL-WN722N 150Mbps 晶片是AEvoque9271

3.操作系统:CentOS 7

4.SD卡8GB

发端在此以前最佳安插好代理,因为编写翻译进程中存有的信赖会联网自动下载,会有半数以上岁月耗在此间,即便速度慢可能被墙……

安排编写翻译境况(应当要非root账户):

#升级组件
sudo yum update
#安装编译组件
sudo yum install libtool autoconf automake gcc-multilib bison screen gcc g   binutils patch bzip2 flex make gettext unzip libc6 git-core git build-essential libncurses5-dev zlib1g-dev gawk quilt asciidoc libz-dev subversion

下载openwrt源码(新手不建议下载trunk,不是很牢固)

#使用非root用户登录,建立openwrt目录
mkdir openwrt
#进入openwrt目录
cd openwrt
#下载openwrt的源码
git clone git://git.openwrt.org/15.05/openwrt.git

集成nodogsplash  在/openwrt/feeds.conf.default中添加

src-git nodogsplash https://github.com/nodogsplash/nodogsplash.git

设置权限

sudo chmod -R 777 trunk
cd trunk

更新并设置

./scripts/feeds update -a
./scripts/feeds install -a

听他们说本人的须要改换系统暗中同意设置,就不细说了,这里列举多少个自己的设置

#这个目录下可以放置之前openwrt的备份文件,也就是说相当于openwrt的/etc/目录
/home/rophie/openwrt/openwrt/package/base-files/files/etc

#默认wifi设置
package/kernel/mac80211/files/lib/wifi/mac80211.sh

network设置

config interface 'loopback'
 option ifname 'lo'
 option proto 'static'
 option ipaddr '127.0.0.1'
 option netmask '255.0.0.0'

config interface 'lan'
 option type 'bridge'
 option proto 'static'
 option ipaddr '192.168.88.1'
 option netmask '255.255.255.0'
 option _orig_bridge 'true'
 option gateway '192.168.88.1'


config globals 'globals'
 option ula_prefix 'fda9:3639:b1e9::/48'

config interface 'wan'
 option ifname 'eth0'
 option _orig_ifname 'eth0'
 option _orig_bridge 'false'
 option proto 'dhcp'

wireless设置  

config wifi-device 'radio0'
 option type 'mac80211'
 option channel '11'
        #这里根据你的USB无线网卡的U口来定
 option path 'platform/bcm2708_usb/usb1/1-1/1-1.5/1-1.5:1.0'
 option noscan '1'
 option country 'CN'
 option hwmode '11n'
 option htmode 'HT40'
 option txpower '40'

config wifi-iface
 option device 'radio0'
 option network 'lan'
 option mode 'ap'
 option ssid 'APK-YFKJ'
 option encryption psk-mixed
     option key 88888888

nodogsplash设置 

config instance
  # Set to 1 to enable nodogsplash
  option enabled 1

  # Use plain configuration file as well
  #option config '/etc/nodogsplash/nodogsplash.conf'
  option network 'lan'
  option gatewayname 'OpenWrt Nodogsplash'
  option maxclients '250'
  option idletimeout '10'
  option clientforcetimeout '10'
  option redirecturl 'http://192.168.88.1:8080'

  # Your router may have several interfaces, and you
  # probably want to keep them private from the network/gatewayinterface.
  # If so, you should block the entire subnets on those interfaces, e.g.:
  #list authenticated_users 'block to 192.168.0.0/16'
  list authenticated_users 'block to 10.0.0.0/8'

  # Typical ports you will probably want to open up.
  list authenticated_users 'allow tcp port 22'
  list authenticated_users 'allow tcp port 53'
  list authenticated_users 'allow udp port 53'
  list authenticated_users 'allow tcp port 80'
  list authenticated_users 'allow tcp port 443'
  list authenticated_users 'allow tcp port 8080'

  # For preauthenticated users to resolve IP addresses in their
  # initial request not using the router itself as a DNS server,
  list preauthenticated_users 'allow tcp port 53'
  list preauthenticated_users 'allow udp port 53'
  #list preauthenticated_users 'allow tcp port 8080'

  # Allow ports for SSH/Telnet/DNS/DHCP/HTTP/HTTPS
  list users_to_router 'allow tcp port 22'
  list users_to_router 'allow tcp port 23'
  list users_to_router 'allow tcp port 53'
  list users_to_router 'allow udp port 53'
  list users_to_router 'allow udp port 67'
  list users_to_router 'allow tcp port 80'
  list users_to_router 'allow tcp port 8080'
  list users_to_router 'allow tcp port 443'

  # See https://github.com/nodogsplash for a full list of available options.

编写翻译配置

#更新版本号
svn up
#进入编译菜单
make menuconfig
Y:选择Y,该软件将被编译,并且加入到你的目标固件里;
M:选择M,该软件包将会被编译,但不会被放入固件里。在需要它的时候,可以用OPKG软件包管理器进行安装;
N:选择N,该软件包将不会被编译,也不会被安装进固件。
方向键是移动光标
回车键是确认
空格键是选择,可以代替Y/M/N键的使用
/:搜索

Target System 选择 brcm2708-bcm2709 按Y选中
金沙澳门官网网址 ,亟待集成的软件

kmod-usb-core kmod-usb-ohci kmod-usb-uhci kmod-usb2 usbutils kmod-ath kmod-ath9k kmod-ath9k-common kmod-ath9k-htc luci-i18n-base-zh-cn kmod-nls-cp437 kmod-nls-utf8 kmod-fs-vfat kmod-nls-iso8859-1 wireless-tools hostapd

编译

make V=99

十分久未来你已经能够在/bin/brcm2708下找到openwrt-brcm2708-bcm2709-sdcard-vfat-ext4.img刷机固件了

 

 

 

  

 

最后效果: 有线路由器的基本点意义,网口WAN接入,USB有线网...

有线路由器的显要职能,网口WAN接入,USB有线网卡AP热门输出,连上wifi之后跳转到认证页面,点击认证方可上网,有效时间10分钟,认证成功今后自动访问内定网站。

小说最终有编译好的刷机包下载

硬件企图:

1.Raspberry Pi 2 model B

2.USB有线网卡,小编动用的是TL-WN722N 150Mbps 微电路是A奥迪Q79271

3.操作系统:CentOS 7

4.SD卡8GB

发端以前最佳布置好代理,因为编写翻译进程中拥有的借助会联网自动下载,会有抢先拾壹分之18日子耗在此处,要是速度慢也许被墙……

布局编写翻译意况(供给求非root账户):

#升级组件
sudo yum update
#安装编译组件
sudo yum install libtool autoconf automake gcc-multilib bison screen gcc g   binutils patch bzip2 flex make gettext unzip libc6 git-core git build-essential libncurses5-dev zlib1g-dev gawk quilt asciidoc libz-dev subversion

下载openwrt源码(新手不提出下载trunk,不是很平稳)

#使用非root用户登录,建立openwrt目录
mkdir openwrt
#进入openwrt目录
cd openwrt
#下载openwrt的源码
git clone git://git.openwrt.org/15.05/openwrt.git

集成nodogsplash  在/openwrt/feeds.conf.default中添加

src-git nodogsplash https://github.com/nodogsplash/nodogsplash.git

设置权限

sudo chmod -R 777 trunk
cd trunk

履新并设置

./scripts/feeds update -a
./scripts/feeds install -a

依赖本人的内需转移系统默许设置,就不细说了,这里列举多少个自己的装置

本文由金沙澳门官网发布于金沙澳门官网网址,转载请注明出处:编译树莓派2代B型OpenWrt固件实现无线路由器及n

关键词: 金沙澳门官网

上一篇:centos7设置jdk意况
下一篇:没有了